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Getting Started with Maxwell: A 2D Magnetostatic Solenoid Problem
Conventions Used in this Guide
Please take a moment to review how instructions and other 
useful information are presented in this guide. 
•    The project tree is the main project area of the Project Man-

ager window. These two terms (project tree and Project 
Manager window) may be used interchangeably in this 
guide.

•    Procedures are presented as numbered lists. A single bullet 
indicates that the procedure has only one step.

•    Bold type is used for the following:

- Keyboard entries that should be typed in their entirety 
exactly as shown. For example, “copy file1” means to 
type the word copy, to type a space, and then to type 
file1.

- On-screen prompts and messages, names of options and 
text boxes, and menu commands. Menu commands are 
often separated by carats. For example, click Max-
well>Excitations>Assign>Voltage.

- Labeled keys on the computer keyboard. For example, 
“Press Enter” means to press the key labeled Enter.

•    Menu commands are often separated by the “>” symbol. 
For example, “Click File>Exit”.

•    Italic type is used for the following:

- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be 
typed in place of the words in italics. For example, 
“copy file name” means to type the word copy, to type a 
space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indicate 
that you should press the keys at the same time. For exam-
ple, “Press Shift+F1” means to press the Shift key and the 
F1 key at the same time.

•    Toolbar buttons serve as shortcuts for executing com-
mands. Toolbar buttons are displayed after the command 
they execute. For example,
 ii
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“Click Draw>Line ” means that you can also click the 
Draw Line toolbar button to execute the Line command.
 iii 
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Getting Help

Ansoft Technical Support
To contact the Ansoft technical support staff in your geo-
graphical area, please go to the Ansoft website, http://
www.ansoft.com, click the Contact button, and then click 
Support. Phone numbers and e-mail addresses are listed for 
the technical support staff. You can also contact your Ansoft 
account manager to obtain this information.
All Ansoft software files are ASCII text and can be sent conve-
niently by e-mail. When reporting difficulties, it is helpful to 
include specific information about what steps were taken or 
what stages the simulation reached. This promotes more 
rapid and effective debugging.

Context-Sensitive Help
To access online help from the Maxwell user interface, do one 
of the following:
•    To open a help topic about a specific Maxwell menu com-

mand, press Shift+F1, and then click the command or tool-
bar icon.

•    To open a help topic about a specific Maxwell dialog box, 
open the dialog box, and then press F1.
 iv
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1 Introduction
Maxwell is an interactive software package that uses finite 
element analysis (FEA) to solve two-dimensional (2D) elec-
tromagnetic problems. 
This guide has been structured to be viewed on your 
screen. The Next and Previous buttons will allow easy 
movement within the document while you are working on 
creating this project. Should you prefer a hardcopy, the 
PDF version is available here:
.
To analyze a problem, you specify the appropriate geome-
try, material properties, and excitations for a device or 
system of devices. The Maxwell software then does the 
following:
• Automatically creates the required finite element mesh.
• Calculates the desired electric or magnetic field solution 

and special quantities of interest, such as force, torque, 
inductance, capacitance, or power loss. The specific types 
of field solutions and quantities that can be computed 
depend on which Maxwell 2D solution type you specified 
(electric fields, DC magnetics, AC magnetics, transient 
fields and data).

• Allows you to analyze, manipulate, and display field solu-
tions.
Introduction 1-1
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Getting Started with Maxwell: A 2D Magnetostatic Solenoid Problem
A sample geometry created with Maxwell appears below: 

This model is actually a three-dimensional (3D) object. Max-
well 2D analyzes the 2D geometry as a cross-section of the 
model, then generates a solution for that cross-section.
In addition to XY models, Maxwell 2D may also be used to 
compute fields in axi-symmetric models to take advantage of 
3D geometry that exhibit rotational symmetry about an axis. 
The geometry described in this guide exhibits such symmetry.
1-2 Introduction 
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The following figure shows the finite element mesh that was 
automatically generated for the 2D geometry:

Dividing a structure into many smaller regions (finite ele-
ments) allows the system to compute the field solution sepa-
rately in each element. The smaller the elements, the more 
accurate the final solution.
Introduction 1-3
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The Sample Problem
The sample problem, shown below, is a solenoid that consists 
of the following objects:
• Core
• Bonnet
• Coil
• Yoke
• Plugnut

The 2D diagram actually represents a 3D structure that has 
been revolved around an axis of symmetry, as shown in the 

CORE

BONNET

YOKE

BACKGROUND

PLUGNUT

COIL
1-4 Introduction 
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figure below. In this figure, part of the 3D model has been cut 
away so that you can see the interior of the solenoid.

Since the cross-section of the solenoid is constant, it can be 
modeled as an axi-symmetric model in Maxwell 2D. Of course, 
material properties, excitations and boundary conditions must 
also be appropriately modeled by an axi-symmetric design.
Introduction 1-5
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Goals
Your goals in Getting Started with Maxwell: A 2D Magnetostatic 
Solenoid Problem are as follows:
•    Determine the force on the core due to the source current 

in the coil.
•    Determine whether any of the nonlinear materials reach 

their saturation point.
You will accomplish these goals by doing the following:
1  Draw the plugnut, core, coil, yoke, and bonnet using the 

Modeling commands.

2  Defining and assigning materials to each object.
3  Defining boundary conditions and current sources required 

for the solution.
4  Requesting that the force on the core be computed, using 

the Parameters section of the project tree.
5  Specifying solution criteria and generating a solution using 

the Add Solution Setup and Analyze commands. You will 
compute both a magnetostatic field solution and the force 
on the core.

6  Viewing the results of the force computation.
7  Plotting saturation levels and contours of equal magnetic 

potential via the Post Processor.
This simple problem illustrates the most commonly used fea-
tures of Maxwell 2D.
1-6 Introduction 
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2 Setting Up the Design
In this chapter you will complete the following tasks:
Open and save a new project.
Insert a new Maxwell design into the project.
Select a solution type for the project.
Set the drawing units for the design.
Setting Up the Design 2-1
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Open Maxwell and Save a New Project
A project is a collection of one or more designs that is saved 
in a single *.mxwl file. A new project is automatically created 
when Maxwell is launched. 
Open Maxwell, add a new design, and save the default project 
with a new name.
To open Maxwell and save a project:
1  Double-click the Maxwell12 icon on your desktop to launch 

Maxwell.

• You can also start Maxwell by clicking 
Start>All Programs>Ansoft>Maxwell12 from Windows.

2  Click Project>Insert Maxwell 2D Design.
The new design is listed in the project tree. By default, it 
is named Maxwell2DDesign1 by default. The Modeler win-
dow appears to the right of the Project Manager (another 
name for the project tree). 

3  Click File>Save As.
The Save As dialog box appears.

4  Locate and select the folder in which you want to save the 
project.

a. Type Solenoid in the File name box, and click Save.

Project Manager
Window 
2-2 Setting Up the Design 
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5  The project is saved in the specified folder under the 
name Solenoid.mxwl. Rename the design:
a. Right-click Maxwell2DDesign1.

A shortcut menu appears.
b. Select Rename.

The design name becomes highlighted and editable.
c. Type a Solenoid as the name for the design, and press 

Enter.
The project and design are now both named Solenoid.

Specify a Solution Type
As mentioned in the introduction, multiple solution types are 
available, depending on the specific application. For this 
design, choose a Magnetostatic solution.
1  Click Maxwell2D>Solution Type from the menus.

The Solution Type dialog box appears.

2  Select the Magnetostatic radio button. 
3  In the Geometry Mode pull-down, select Cylindrical about Z.
4  Click OK.

Set the Drawing Units
1  Click Modeler>Units.

The Set Model Units dialog box appears.

2  Select in (inches) from the Select units pull-down menu.
3  Click OK.

Note Many commands in the Maxwell2D menu are also available by 
Right-Clicking on various section of the project tree. For 
example, Right-Click on Solenoid (Magnetostatic about Z) in the 
project tree and you can select and change the Solution Type 
from the pop-up menu.
Setting Up the Design 2-3
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3 Creating the 
Geometric Model
In this chapter you will complete the following tasks:
Use the rectangle drawing mode to create a 
solenoid plugnut.
Create the solenoid’s core, yoke and bonnet 
objects using the polyline command.
Explore the use of keyboard entry mode in 
creating the coil, yoke and bonnet objects.
Create the solenoid coil.
Create the background object.
Creating the Geometric Model 3-1
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Create the Geometry
The solenoid is made up of five objects: a plugnut, core, coil, 
yoke, and bonnet. All objects are created using the Draw com-
mands as described in the following sections.
The dimensions of the solenoid that you will be modeling are 
shown below. For axi-symmetric structures, the axis of sym-
metry is the Z-axis, and drawing is preformed in the XZ plane 
will all objects in the X>0 portion of the plane. You will use 
these dimensions, which are given in inches, to create the 
geometric model.

The following pages step you through drawing the above 
model.

Draw the Plugnut
First, draw the plugnut using the rectangle command.

0.05

0.05
0.75

0.05

0.4

1.5

1.0

1.750.05

0.3

0.05

0.2

0.1

0.15
0.227

0.075
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0.2

0.05

0.1

1.35
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To create the plugnut:
1  Click Draw>Rectangle.

The cursor changes to a small black box, indicating that 
you are in Drawing mode.

2  Select one corner of the rectangle by clicking at the 
(0,0,-0.2) location, and press the TAB key to jump to the 
manual entry area in the Status Bar at the bottom of the 
screen.

3  Notice the Status Bar is prompting for the Opposite corner 
of the Rectangle. Type 0.3 in the dX box, ensure that dY is 
set to zero, and type -1.0 in the dZ box. Press Enter to 
complete the creation of the rectangle. The default prop-
erties appear in the Properties Window.

4  In the Attribute tab, change the Name (currently 
Rectangle1) to Plugnut by clicking on Rectangle1. The field 
becomes editable and you can enter Plugnut as the new 
object name.

5  Optionally change the color of the rectangle to blue:
a. In the Color row, click the Edit button.

The Color palette dialog box appears.
b. Select any of the blue shades from the Basic colors group, 

and click OK to return to the Properties window. The 
object color change will not be apparent while it is cur-
rently selected.

6  Optionally, click the Command tab to view and edit the 
geometric data. For this example, we do not need to edit 
the geometric data.

7  Optionally, when using the pop-up Properties dialog, click 
OK to close the Properties window. A rectangle named 
Plugnut is now part of the model. 

Note Optionally, you may use the pop-up Properties Window 
by configuring user options.

Note You can also view the Command tab by double-clicking 
the CreateRectangle entry in the history tree window.
Creating the Geometric Model 3-3
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Draw the Core
Next, use the polyline command to create the core.
To create the core:
1  First you need to adjust the grid settings by clicking 

View>Grid Settings. In the Grid Spacing dialog de-select the 
Auto adjust density checkbox and enter 0.05 in each of the 
dX, dY, and dZ value fields.

2  Click Draw>Line.
The cursor changes to a small black box, indicating that 
you are in Drawing mode.

3  Select the first vertex by clicking at the (0.1, 0, 1.2) 
location. The first vertex is locked in and you may now 
move the cursor to the location of the second vertex 
(0.1, 0, -0.15).

4  Continue creating the core object by clicking at each of 
the points in the table in succession.

Note The first vertex may be outside the viewable drawing area. If 
so, hold down the Shift key and move the mouse slightly. The 
mode will switch to Pan mode. While continuing to hold the 
Shift key down, press and hold the left mouse button. Drag 
the mouse to pan the modeler window and make more of the 
positive Z-axis available. Releasing the mouse button and 
shift key exits Pan mode automatically. 

Table 1: 

X Y Z

0.2 0 -0.15

0.2 0 -0.1

0.3 0 -0.1

0.3 0 1.2

0.1 0 1.2
3-4 Creating the Geometric Model 



Getting Started with Maxwell: A 2D Magnetostatic Solenoid Problem
5  After Entering the final vertex twice, an object named 
polyline1 is created. The Properties window contains the 
default information for the newly created object.

6  Click the Attribute tab.
7  Change the Name to Core. 
8  Optionally change the color of the Core object to green.

Keyboard Entry
When creating objects in the modeler, you may use the cursor 
or manually enter coordinates. Manual entry is particularly 
useful when the dimensions fall between the grid spacing. 
In order to manually enter points, click the TAB key and the 
system focus is moved from the drawing window to the key-
board entry area of the status bar allowing entry of direct 
vertices or dimensions depending upon the object being cre-
ated. The status bar also contains prompts to assist with the 
manual entry process.
Once in manual entry mode, you may continue to press the 
TAB key to switch between the entry fields.

Draw the Coil
Now draw the coil object using the keyboard entry technique 
discussed in the previous section.
To create the coil:
1  Click Draw>Rectangle.

The cursor changes to a small black box, indicating that 
you are in Drawing mode.

0.1 0 1.2

Note Selecting the final vertex twice causes the modeler to 
end the polyline creation process. Since the polyline 
creates a closed polygon, a 2D sheet object is 
automatically created from the series of vertices.

Table 1: 

X Y Z
Creating the Geometric Model 3-5
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2  Press the TAB key to switch the focus to the keyboard 
entry area at the bottom of the screen.

3  Enter the coordinate (0.375, 0, 0.7) for the rectangle 
position. Pressing the TAB key switches between the fields 
for easy data entry. Press Enter once the coordinate data 
is entered.

4  The Status Bar now prompts for the opposite corner of the 
rectangle. Using the TAB key to switch between fields, 
enter the values for the dimensions of the coil. Type 0.4 
for dX, 0 for dY, and -1.5 for dZ. Press Enter to complete 
the creation of the rectangle. The default properties 
appear in the Properties Window.

5  In the Attribute tab, change the Name (currently 
Rectangle1) to Coil. 

6  Optionally change the color of the rectangle to Red:
a. In the Color row, click the Edit button.

The Color palette dialog box appears.
b. Select any of the red shades from the Basic colors group, 

and click OK to return to the Properties window.

Draw the Yoke
Next, use the polyline command to create the yoke of the 
solenoid.
To create the yoke:
1  Click Draw>Line.

Press the TAB key to enter keyboard entry mode.

Note Do not move the mouse once the focus has switched to 
the keyboard entry area or the system will revert back to 
mouse entry mode and any data that has been manually 
entered will be lost.

Note You may enter the exact location of the opposite corner 
of the rectangle by switching the entry mode from 
relative to absolute using the pull-down listbox.
3-6 Creating the Geometric Model 
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2  Create the yoke object by entering each data point from 
the table below followed by the Enter key.

3  After Entering the final vertex, press the Enter key twice. 
An object named polyline1 is created. The Properties win-
dow contains the default information for the newly cre-
ated object.

4  Click the Attribute tab.
5  Change the Name to Yoke. 
6  Optionally change the color of the Yoke object to purple.

Table 2: 

X Y Y

0.35 0 -1.05

1.1 0 -1.05

1.1 0 0.8

0.35 0 0.8

0.35 0 0.75

1.05 0 0.75

1.05 0 -1.0

0.35 0 -1.0

0.35 0 -1.05

Note Selecting the final vertex twice causes the modeler to 
end the polyline creation process. Since the polyline 
creates a closed polygon, a 2D sheet object is 
automatically created from the series of vertices.
Creating the Geometric Model 3-7
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Draw the Bonnet
As in the previous section, use the polyline command in key-
board entry mode to create the bonnet of the solenoid.
To create the bonnet:
1  Click Draw>Line.

Press the TAB key to enter keyboard entry mode.

2  Create the bonnet object by entering each data point from 
the table below followed by the Enter key.

3  After Entering the final vertex, press the Enter key twice. 
An object named polyline1 is created. The Properties win-
dow contains the default information for the newly cre-
ated object.

4  Click the Attribute tab.
5  Change the Name to Bonnet. 
6  Optionally change the color of the Bonnet object to light 

blue.
7  The geometric model should appear as shown in the fol-

lowing graphic:

Table 3: 

X Y Y

0.35 0 0.8

0.5 0 0.8

0.5 0 0.95

0.425 0 0.95

0.425 0 1.177

0.35 0 1.177

0.35 0 0.8
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8  Click File>Save to save all of the operations up to this 
point.

Create the Background (Region)
Define a background region box with the origin at (0, 0, -2) 
and the dimensions of (2, 0, 4).
To create the background region box:
1  Click Draw>Rectangle.

2  Type the box position (0, 0, -2) in the X, Y, and Z fields at 
the bottom of the screen, and then press Enter.

3  Type the box size (2, 0, 4) in the dX, dY, dZ fields, and 
then press Enter.
The Properties window contains the default information for 
the newly created object.

4  Click the Attribute tab.
5  Change the Name (currently Rectangle1) to bgnd. 
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6  Set the transparency to 0.9:
a. Click the button for the Transparent property.

The Set Transparency dialog box appears.
b. Type 0.9 in the text box, and click OK to return to the 

Properties window.

7  The final geometry should look similar to the following:

8  Click File>Save to save the final version of the model 
before moving on to defining materials.

Note Alternatively, the Draw>Region command may be used to 
create the background object.
3-10 Creating the Geometric Model 

oldfriend
底線

oldfriend
反白



4 Setting Up the 
Solenoid Model
In this chapter you will complete the following tasks:
Assign materials with the appropriate material 
attributes to each object in the geometric model.
Define any boundary conditions and sources that 
need to be specified, such as the source current 
of the coil.
Request that the force acting on the core be 
calculated during the solution.
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Assign Materials to Objects 
The next step in setting up the solenoid model is to assign 
materials to the objects in the model. Materials are assigned 
to objects via the Properties Window. You will do the follow-
ing:
•    Assign copper to the coil.
•    Define the material cold rolled steel (a nonlinear magnetic 

material) and assign it to the bonnet and yoke.
•    Define the material Neo35 (a permanent magnet) and 

assign it to the core.
•    Define the material SS430 (a nonlinear magnetic material) 

and assign it to the plugnut.
•    Accept the default material that is assigned to the back-

ground object, which is vacuum.

Access Material Database
To access the Material Database, select the coil object by 
clicking in the Model Window or by selecting it in the history 
tree. Once you have selected the coil, click in the Material 
Value field of the Properties Window. The Select Definition 
dialog appears to allow material definitions to be assigned to 
the selected object.
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Assign Copper to the Coil
In the actual solenoid, the coil is made of copper. Scroll the 
database table down to the definition of copper in the Mate-
rial Manager and select it by clicking on the name field. Then 
click OK. The Properties Window will now show copper in the 
Material Value field for the coil object and coil will be listed 
under copper in the Object list.
The general procedure to assign a material to an object:
1  Select the object that is to be assigned a material in one 

of two ways:

• Click the name in the Object list.
• Click on the object in the geometry window.
Both the object and its name are highlighted.

2  Select the Material Value field in the Properties Window.
3  Scroll to and select the material of interest from the Mate-

rial database listing. You may also use the Search Parame-
ters section of the dialog to narrow the search or jump 
quickly through the database listing.

4  Click the OK button to complete the assignment.

Assign Cold Rolled Steel to the Bonnet and 
Yoke 
The bonnet and yoke of the solenoid are made of cold rolled 
steel. Since this material is not in the database, you must cre-
ate a new material, ColdRolledSteel. This material is nonlinear 
— that is, its relative permeability is not constant and must be 
defined using a B vs. H curve. Therefore, when you enter the 
material attributes for cold rolled steel, you will also define a 
B-H curve.

Select Objects and Create the Material
To select the objects and create the new material:
1  Select both the bonnet and yoke (click on the bonnet and 

then, while holding the Ctrl key down, click on the yoke).

2  Click the Material Value field from the Properties Window.
3  Select Add Material. The View/Edit Material dialog appears.
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4  Under Material Name, change the name of the new mate-
rial from Material1 to ColdRolledSteel.

5  Change the Relative Permeability type field from Simple to 
Nonlinear by clicking in the Type field to view the avail-
able options and selecting Nonlinear. The Rel. Permeability 
value field changes to a button labeled BH Curve.

Define the B-H Curve For Cold Rolled Steel
To define the properties of cold rolled steel, use the BH Curve 
button to define a B-H curve giving the relationship between 
B and H in the material.
To define the B-H curve, click BH Curve in the Relative Permea-
bility value field. The B-H Curve Entry window appears. 

On the left is a blank BH-table where the B and H values of 
individual points in the B-H curve are displayed as they are 
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entered. On the right is a graph where the points in the B-H 
curve are plotted as they are entered.

Add B-H Curve Points for Cold Rolled Steel
To enter the points in the B-H curve:
1  Click in the table entry area under the H column, row 1.

2  Enter 0.0 for the minimum H value and press the TAB key.
3  Enter 0.0 for the minimum B value and press the TAB key.
4  Enter the rest of the values for the B-H curve from the 

table below, using the TAB key to accept the entry and 
move to the next available cell.

Note When defining B-H curves, keep the following in mind:
• A B-H curve may be used in more than one model. To do 

so, save (export) it to a disk file, which can then be 
imported into other 2D models. 

• Maxwell 3D can read B-H curve files that have been 
exported from Maxwell, enabling you to use the same 
curves for both 2D and 3D models.

In this guide, you will not be exporting them to files.

Table 4: 

H B

0.0 0.0

1080 0.858

1480 1.06

2090 1.26

3120 1.44

5160 1.61

9930 1.77

1.55e4 1.86

2.50e4 1.88

3.50e4 1.90
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5  The graph automatically updates as each data point is 
entered. The software automatically fits a curve to the 
points you entered and displays a list of all B-H curve 
points, as shown below:

6  After you enter the last value press Enter to exit data 
entry mode and click OK to return to the View/Edit Material 
window.

Assign ColdRolledSteel to the Yoke and Bonnet
Now that you have completed the B-H curve entry, enter 
ColdRolledSteel into the database and assign it to the selected 
objects:

Note Numeric values — like the minimum and maximum B and H 
values — may be entered and displayed in Ansoft’s shorthand 
for scientific notation. For instance, 35000 could also be 
entered as 3.5e4. When entering numeric values, you can use 
either notation.
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To save and assign the new material:

1  Click OK in the View/Edit Material dialog to save the material 
properties you have entered for ColdRolledSteel — includ-
ing the B-H curve you have just defined — and add it to the 
material database.

ColdRolledSteel then appears highlighted in the database 
listing. The word Project appears next to it in the location 
field, indicating that this material is specific to the sole-
noid project.

2  Click OK to assign ColdRolledSteel to the yoke and bonnet.

Assign Neo35 to the Core
Next, create a new material Neo35, and assign it to the core. 
Neo35 is a permanently magnetic material.

Select the Object and Create the Material
To select the core and create the material:
1  Select core from the Object list. 

2  Click the Material Value field in the Properties Window.
3  In the Select Definition dialog, select Add Material. The 

View /Edit Material dialog is displayed.
4  Under Material Name, change the name of the new mate-

rial to Neo35.

Note In the actual solenoid, the core was assigned the same material 
as the plugnut. However, for this problem, a permanent magnet 
is assigned to the core to demonstrate how to set up a 
permanent magnetic material. 
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Select Independent Material Properties
In magnetostatic problems, only two of the four available 
material properties need to be specified. In Maxwell, you may 
enter only the Permeability(m) and the Magnetic Coerciv-
ity(Hc). The values of the other two properties are dependent 
upon these properties, according to the relationships shown 
below.

The values of the other two properties, magnetic retentivity, 
Br, and magnetization, Mp, are computed using the relation-
ships shown above. You may use the “Calculate Properties 
for” pull down to calculate one set of properties from the 
other.
To calculate the properties to be entered:
1  Select the Calculate Properties for... pull down list and 

choose Permanent Magnet. The Properties for Permanent 

Magnet window appears.

2  Enter 1.05 in the Rel. Permeability (Mu) field but do not 
press Enter.

3  Click on the check box next to Hc to de-select it.
4  Click on the check box next to Br/Mp to select it.
5  Enter 1.25 in the Mag. Retentivity (Br) field and press the 

TAB key or use the mouse to change the dialog focus. Val-
ues automatically appear in the remaining fields.

6  Press OK to accept all the values and close the dialog. 
When using the Calculate Properties dialog, all data is 
automatically transferred when the dialog closes.

B

H

Hc
Magnetic
Coercivity

Br
Magnetic

Retentivity Br μoMp μoμrHc= =

μ = Br/Hc
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Enter Material Properties
The View/Edit Material dialog should now have the values for 
Relative Permeability and Magnetic Coercivity entered in the 
dialog.

Optionally - To enter the properties for Neo35 manually:
1  Enter 1.05 in the Rel. Permeability (Mu) field.

2  Enter -947350.85 in the Mag. Coercivity Magnitude (Hc) 
field.
Since the Mag. Coercivity is a vector quantity, the dialog 
will update with entry fields for the X, Y, and Z vector 
components to specify the direction of the vector.

Also, verify that the Material Coordinate System Type list-
box at the top of the dialog is set to Cartesian.

3  Click OK. Neo35 is now listed as a local material in the 
database.

Assign Neo35 to the Core and Specify Direction of Magnetization
Now that you have created the material Neo35, all that 
remains is to assign it to the core and specify the direction of 
magnetization. 
By default, the direction of magnetization in materials is 
along the R-axis (or the x-axis). However, in this problem, the 
direction of magnetization in the core points along the posi-
tive z-axis. To model this, you must change the direction of 
magnetization to act at a 90o angle from the default.
To assign Neo35 to the core:
1  Make certain that Neo35 is highlighted in the Material list.

2  Click OK in the Select Definition dialog to assign the material 
Neo35 to the core object. In the Properties Window, the 
Orientation property is automatically set to Global.

Note By default, most material properties in the database shipped 
with Maxwell will be oriented along the x-axis (1, 0, 0) when a 
vector orientation is required. Other orientations require the 
user to create a coordinate system and align the material with 
it in order to change the orientation vector once it has been 
specified in the material database.
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Create a Relative Coordinate System for the Magnet Orientation
Since material properties must be aligned with a coordinate 
system, you will now create one that is rotated 90o.
1  Click Modeler>Coordinate System>Create>Rela-

tiveCS>Rotated. 

2  Using the mouse, align the X-axis of the new coordinate 
system with the Z-axis of the global coordinate system and 
click the mouse. A new coordinate system RelativeCS1 is 
created and automatically set to be the current working 
coordinate system.

Complete the Alignment of the Magnet
1  Make sure the core object is selected.

2  In the Properties Window select the Value cell next to Ori-
entation. A pop up selection is displayed listing the coordi-
nate systems available in the project.

3  Select RelativeCS1. This completes the alignment of the 
Magnetic Coercivity for the core object.

Note You may also use keyboard entry mode to specify the new 
coordinate system by pressing TAB on your keyboard. This will 
shift the focus to the data entry area at the bottom of the 
screen where you can enter exact values for the coordinate 
point, in this case (0, 0, 1). Pressing the TAB key also allows you 
to navigate between the X, Y and Z entry boxes quickly.
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4  You may wish to return to the Global Coordinate system. 
To do so, click on Global in the history tree under Coordi-
nate Systems as shown in the figure below.

Create SS430 Material and Assign to Plugnut 
Next, create a new material — SS430 — for the plugnut. Like 
the material ColdRolledSteel, it is a nonlinear material whose 
relative permeability must be defined using a B-H curve. The 
first step included selecting the plugnut and creating the 
material.

Select Objects and Create Material
To select the plugnut, and create the material:
1  Select plugnut from the Object list. 

2  Click the Material Value field in the Properties Window.
3  In the Select Definition dialog, click on Add Material.
4  Under Material Name, change the name of the new material 

to SS430.
5  Select the Relative Permeability type field and change it 

from Simple to Nonlinear. The value field changes to a but-
ton labeled BH Curve.

Define the B-H Curve for SS430
To define the B-H curve for SS430, click the B-H curve button.
The B-H Curve Entry window appears.
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Add B-H Curve Points for SS430
Enter the points in the B-H curve according to the table 
below:
1  Select the H column, row 1 and enter 0.0. Press the TAB 

key to accept the entry and move to the next cell.

2  Use the Append Rows button to add 9 additional rows to 
the table to accommodate the data below.

3  Enter the following points using keyboard entry.

Table 5: 

H B

0.0 0.0

143 0.125

180 0.206

 219 0.394

 259 0.589

 298 0.743

 338 0.853

 378 0.932

 438 1.01

 517 1.08

 597 1.11

 716 1.16

 955 1.20

 1590 1.27
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4  After you enter the last value press Enter to accept the 
last data point and click OK to return to the View/Edit 
Material window.

Assign SS430 to the Plugnut
Finally, add SS430 to the material database, and assign it to 
the selected object:
To save and assign SS430:
1  Click OK in the View/Edit Material dialog to save the material 

properties you have entered for SS430 — including the B-H 
curve you have just defined — and add it to the material 
database.

2  Make certain SS430 is highlighted. Click OK in the Select 
Definition dialog to save the material attributes you 
entered for SS430 and assign it to the plugnut object

 3980 1.37

 6370 1.43

1.19e4 1.49

2.39e4 1.55

3.98e4 1.59

Table 5: 

H B
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Accept Default Material for Background
Accept the following default parameters for the background 
object bgnd:
•    The object bgnd is the only object that will use the mate-

rial assigned by default. At the time an object is created, 
a default material is assigned and is visible in the Proper-
ties Window. 

•    The default material, vacuum, is acceptable to use for the 
bgnd in this model.

Note During the model creation process, the material may be 
assigned immediately to the object before continuing to 
create the next object. This may have some advantages since 
copying an object with a material assigned will preserve the 
material assignment for the copy objects and may reduce the 
need for material assignments.
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Set Up Boundaries and Current Sources
After you set material properties, you must define boundary 
conditions and sources of current for the solenoid model. 
Boundary conditions and sources are defined through the 
Boundaries and Excitations entries in the Project tree or 
through the Maxwell2D>Boundaries and Maxwell2D>Excitations 
menus respectively.
By default, the surfaces of all objects are Neumann or natural 
boundaries. That is, the magnetic field is defined to be per-
pendicular to the edges of the problem space and continuous 
across all object interfaces. To finish setting up the solenoid 
problem, you must explicitly define the following boundaries 
and sources:
•    The boundary condition at all surfaces exposed to the area 

outside of the problem region. Because you included the 
background as part of the problem region, this exposed 
surface is that of the object bgnd. Since the solenoid is 
assumed to be very far away from other magnetic fields or 
sources of current, those boundaries will be defined as 
“balloon boundaries.”

•    The source current on the coil. Since the coil has 10,000 
turns of wire, and one ampere flows through each turn, 
the net source current is 10,000 amperes.

Note Maxwell 2D will not solve the problem unless you specify some 
type of source or magnetic field — either a current source, an 
external field source using boundary conditions, or a 
permanent magnet. In this problem, both the permanent 
magnet assigned to the core and the current flowing in the coil 
act as magnetic field sources.
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Types of Boundary Conditions and Sources
There are two types of boundary conditions and sources that 
you will use in this problem:

You will assign boundary conditions and sources to the follow-
ing objects in the solenoid geometry:

Set Source Current on the Coil
Before you identify a boundary condition or source, you must 
first identify the object or surface to which the condition is to 
be applied. In this section, you will pick the coil as a source 
and then assign a current to it.

Balloon 
boundary

Can only be applied to the outer boundary. 
Models the case in which the structure is 
infinitely far away from all other electromagnetic 
sources.

Current 
source

Specifies the DC source current flowing through 
an object in the model.

bgnd At the outer boundary of the problem region, the 
outside edges of this surface are to be ballooned 
to simulate an insulated system. The edge along 
the Z axis will not be assigned since this is the 
axis of rotation for this Cylindrical about Z 
problem.

Coil This object is to be defined as a 10,000-amp DC 
current source. The current is uniformly 
distributed over the cross-section of the coil and 
flows in the positive perpendicular direction to 
the cross-section.
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Assign a Current Source to the Coil
To specify the current flowing through the coil:
1  Select the coil object by clicking on the object in the mod-

eler window or selecting the object in the history tree.

2  Click Maxwell2D>Excitations>Assign>Current. The Current 
Excitation dialog appears. 
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3  Enter 10000 in the Value field and ensure the units are set 
to Amps.

4  Ensure the Ref. Direction is set to Positive to indicate 
current flowing in the positive PHI direction, in this case, 
into the screen.

5  Click OK to complete the assignment of the source named 
Current1 to the coil object. 

6  Current1 is now listed under the Excitations section of the 
Project tree.

Note In Magnetostatic problems, the current is always distributed 
uniformly through the object. In addition, Positive is in the 
positive Z direction for XY problems, and positive PHI for RZ 
problems.
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Assign Balloon Boundary to the Background
The structure is a magnetically isolated system. Therefore, 
you must create a balloon boundary by assigning balloon 
boundaries to the outside edges of the background object.

Pick the Background
To select the edges of the background to use as a boundary:
1  Click Edit>Select>Edges, select the three edges of the 

background object that correspond to the open region as 
shown. Click the first edge and the click the remaining 

edges while holding down the Ctrl key.

2  Click Maxwell2D>Boundaries>Assign>Balloon.
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3  The Balloon Boundary dialog appears with balloon1 in the 
Name field. Click OK to accept the default name.

4  Balloon1 now shows up in the Project tree under the 
Boundaries section

You are now ready to set up the force computation for the 
model.

Set Up Force Computation 
One of your goals for this problem is to determine the force 
acting on the core of the solenoid. To find the force on this 
object, you must select it and assign the force parameter. The 

Note In cartesian (XY) models, all outer edges may be defined as 
boundaries. However, in axisymmetric (RZ) models, the left 
edge of the problem region cannot be assigned a balloon 
boundary condition. Because the solenoid model is 
axisymmetric (representing the cross-section of a device that’s 
revolved 360 degrees around its central axis). Instead, it 
automatically imposes a different boundary condition to model 
that edge as an axis of rotational symmetry.
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force (in newtons) acting on the core will then be computed 
during the solution process.
To select the core object for the force computation:
1  Click Edit>Select>Objects in the menu. Click on the core 

object in the modeler window.

2  Click Maxwell2D>Parameters>Assign>Force in the menu. 
The Force Setup dialog appears.

3  Click OK to select the default name and assign the force 
computation to the core object. 

4  The force computation now appears tin the project tree 
under Parameters.

You are now ready to enter the Inductance computation.

Set Up Inductance Computation 
In addition to the force on the core, the coil inductance is of 
interest. 
To set up the inductance computation:
1  Click Maxwell2D>Parameters>Assign>Matrix in the menu. 

The Matrix setup dialog appears.

2  Click the Include checkbox next to Current1 to select the 
current excitation for use in a matrix calculation. 
Since there is only one excitation defined in this problem, 
the return current must be set to the default (infinite); 
however, in an axisymmetric model the current returns in 
the coil itself since it is rotated 360 degrees about the Z-
axis.

3  Click OK.
4  Click File>Save to save all the changes for Boundary, Exci-

tation, and Parameter setup.
You are now ready to enter the solution criteria.
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5 Generating a Solution
Now you are ready to specify solution parameters and 
generate a solution for the solenoid model. You will 
do the following:

View the criteria that affect how Maxwell 2D 
computes the solution.
Generate the magnetostatic solution. The 
axisymmetric magnetostatic solver calculates the 
magnetic vector potential, Aφ, at all points in the 
problem region. From this, the magnetic field, H, 
and magnetic flux density, B, can be determined.
Compute the force on the core. Since you 
requested force using the Parameters command, 
this automatically occurs during the general 
solution process.
View information about how the solution 
converged and what computing resources were 
used.
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Add Solution Setup
Use the default criteria to generate the solution for the sole-
noid problem.
1  In the Project tree right-click Analyze and select Add Solu-

tion Setup.

. 
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2  The Solve Setup window appears.

When the system generates a solution, it explicitly calculates 
the field values at each node in the finite element mesh and 
interpolates the values at all other points in the problem 
region.

Adaptive Analysis
In the Adaptive Setup section of the General Tab, do the fol-
lowing to have the system adaptively refine the mesh and 
solution:
1  Enter 10 in the Maximum Number of Passes field for the 
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maximum number of adaptively refined solution passes to 
complete.

Doing so instructs the system to solve the problem itera-
tively, refining the regions of the mesh in which the largest 
error exists. Refining the mesh makes it more dense in the 
areas of highest error, resulting in a more accurate field 
solution.

2  Leave Percent refinement per pass set to its default value 
of 1%.
The Percent Error field tells the software what target 
error to achieve within the number of passes allowed. If 
this percent error is reached the solution process will ter-
minate even though additional adaptive passes may be 
available. In most cases, the default refinement value is 
acceptable to provide an accurate solution in reasonable 
time. 

If any of these criteria has been met, the solution process is 
complete and no more iterations are done.

Parameters
The Parameters section of the General Tab allows the user to 
specify when requested Parameters should be solved. For this 
solution, make sure that the Solve Fields Only box is not 
checked, allowing the force solution to be calculated after 
each adaptive solution.

Note After each iteration, the system calculates the total energy of 
the system and the percentage of this energy that is caused 
by solution error. It then checks to see if the number of 
requested passes has been completed, or if the percent error 
and the change in percent error between the last two passes 
match the requested values.
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Mesh Refinement Criteria
In the Convergence Tab, the Standard section refers to the 
mesh refinement to be used during adaptive analysis. 
1  Set the Refinement Per Pass to 30% to tells the software to 

increase the number of mesh triangles by up to 30 percent 
after each adaptive solution.

2  Set Minimum Number of Passes to 2 to force the system to 
solve at least two passes, regardless of the solution accu-
racy calculated after the initial solution.

3  Set the Minimum Converged Passes to 1. Setting a higher 
number will force multiple successive solutions to be 
below the Percent Error criteria before stopping the solu-
tion process.

Solver Residual
In the Solver Tab, leave the Nonlinear Residual field set to 
.0001. This value specifies how close each solution must come 
to satisfying the equations that are used to compute the mag-
netic field. All other fields should remain at their default val-
ues.
Select OK at the bottom of the dialog to complete the Solve 
Setup process
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Start the Solution 
Now that you have set up the solution parameters, the prob-
lem is ready to be solved. 
•    To start the solution, right-click Setup1>Analyze in the 

Project Manager window.
The system creates the initial finite element mesh for the 
solenoid structure. A progress bar appears in the Progress box 
at the bottom of the screen. It shows the system’s progress as 
it generates the mesh and computes the adaptive solutions.
The solution may be stopped by right-clicking on the progress 
window as shown.

Values you obtain for percent energy error, total energy, or 
force may differ slightly from the ones given in this guide. 
Depending upon how closely you followed the directions for 
setting up the solenoid model, the results that you obtain 
should be approximately the same as the ones given here.
Once the solution process has completed, or in the case of an 
error, the Message Manager window will display information 
regarding the reason for the solution process termination. In 
this case you should see the following message:

Normal completion of simulation on server: Local Machine

Note After a solution is generated, the system will invalidate your 
solution if you change the geometry, material properties, or 
boundary conditions of the model. Therefore, you must 
generate a new solution if you change the model.
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Monitoring The Solution
You may monitor the solution progress while the simulation is 
running by right-clicking on the solution setup entry in the 
Project Manager. The following information is available while 
the simulation is running.

•    Profile displays the Profile Tab of the Solution dialog 
which lists the computer resource (memory and computa-
tion time) usage for each process in the simulation and the 
running total.

•    Convergence shows the mesh size, error calculation, and 
delta energy for each adaptive pass in the solution.
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•    Solutions displays the results of the Parameter calcula-
tions, in this case, the force calculated on the core.

•    The Mesh Statistics option displays the Mesh Statistics Tab 
of the Solution dialog. Here you can view the number of 
triangles and various triangle properties for each object in 
the solution.

Viewing Convergence Data
Now that the solution has completed, you can review the 
solution information to judge the accuracy and suitability of 
the solution. Right-Click on Setup1 in the Project Manager and 
select Convergence to monitor how the solution is progressing. 

Note If a problem does not begin to converge after several adaptive 
passes, the problem is probably ill-defined — for instance, 
boundary conditions may not have been specified correctly. If 
this ever happens, do the following to interrupt the solution 
process:
1. Right-Click the Progress Bar and select Abort. 
2. Check the problem definition, and then solve the problem 

again.
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Convergence information appears as shown below. In this 
example, the system has completed 8 adaptive passes.

Solution Criteria
Information about the solution criteria is displayed on the left 
side of the convergence display.

Number of passes Displays how many adaptive passes have been 
completed and still remain.
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Completed Solutions
Information about each completed solution is displayed on 
the right side of the screen.

Target
Error

Displays the percent error value — 1% — that 
was entered during Add Solution Setup.

Energy 
Error

Displays the percent error from the last 
completed solution — in this case, 0.69%. 
Allows you to see at a glance whether the 
solution is close to the desired error energy. 
Because this value is less than the Target Error, 
the solution was considered to be converged. 

Delta 
Energy

Displays the change in the percent error 
between the last two solutions — in this case, 
0.003%. 

Note Your individual solution may differ slightly due to machine 
differences and meshing differences with each release of the 
software.

Pass Displays the number of the completed 
solutions. In the previous figure, 8 adaptive 
passes were completed.

Triangles Displays the number of tetrahedrons in the 
mesh for a solution. In the previous figure, the 
mesh used for the eighth solution had 880 
triangles.

Total Energy (J) Displays the total energy of a solution in 
Joules. In the previous figure, the total energy 
for the sixth solution was 1.9385 Joules.

Delta Energy (%) Displays the change in Total Energy between 
the current and previous expressed as a 
percentage of the previous pass energy. In the 
previous figure, the Delta Energy for the sixth 
pass was 0.010804%.

Energy Error (%) Displays the percent energy error of the 
completed solutions. In the previous figure, the 
energy error for the eighth solution was 
0.698%.
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Plotting Convergence Data
By default, convergence data is displayed in table format as 
shown in the previous figure. This data can also be displayed 
graphically. 
To plot the Energy Error computed during each adaptive pass:
•    On the Convergence Tab, click the Plot radio button. Use 

the drop-down menu to select Energy Error for the Y-axis. 
The following plot appears:

Displaying this data graphically often makes it easier to see 
how the solution is converging. 
Optionally, use the other commands under Convergence Dis-
play to plot the number of triangles, total energy, or delta 
energy for all adaptive passes.
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Viewing Statistics 
Click the Profile tab to see what computing resources were 
used during the solution process. The following screen 
appears.

The time that the solution process began is displayed at the 
top of the box. Beneath it, the following information is 
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displayed for each adaptive field solution and mesh refine-
ment step that was completed:

If more data is available than can fit on a single screen, scroll 
bars appear. To display more data, manipulate the display as 
described in 
Click the Close button at the bottom of the Solutions dialog. 
You are now ready to move on to post processing the solution 
and evaluate the fields and parameters calculated for this 
model.

Task Displays the name of the system command that 
was used.

Real time Displays the time taken to complete the step.
Cpu time Displays the amount of time taken by the CPU 

(central processing unit) to complete the step.
Memory Displays the amount of memory used.
Information Displays the of number of triangles, number of 

CPUs, and various other information for the 
process.
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6 Analyzing the Solution
Now that you have generated a magnetostatic 
solution for the solenoid problem, you can analyze it 
using Maxwell 2D’s post processing features.

Examine the computed force values.
Plot the magnetic flux and magnetic fields in and 
around the solenoid.
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View Force Solution
Now that the solution is complete, examine the results of the 
force computation. 
To view the force results, right-click on the Force1 entry in 
the Parameter section of the Project Manager as shown and 
select View Solution.
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The final force value computed during the adaptive solution 
appears as shown below. Note that your values may differ 
slightly from those shown:

The net force on the core is approximately 117 newtons, act-
ing in the negative Z direction (pulling the core down into the 
solenoid). There is no component of force in the R direction 
because of the axial symmetry. Click Close to dismiss the win-
dow.

Plot the Magnetic Field
You will now create a field plot of the Magnetic Field in the 
entire problem region.
1  You must first select one or several objects in the problem 

region on which to create a field plot. Click the mouse 
anywhere in the Modeler window and press Ctrl+A. This 
will select all objects in the model.
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2  From the Field Overlays section of the Project Manager (or 
the Maxwell2D>Fields menu), select Fields>H>MagH com-
mand to plot the magnetic field magnitude throughout the 
selected problem region. 
The Create Field Plot window appears.

3  Mag H, and In Volume All are selected by default due to the 
procedure used to launch the dialog. Also note that the 
dialog defaults to the LastAdaptive pass data to plot.

4  Optionally, a plot on only the edge of the selected Volume 
may be obtained by selecting the Plot on edge only check-
box.
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5  Click Done. The Mag H plot shown below appears.

6  Double-click on the color key and the Modify Plot dialog is 
displayed. Click the Scale tab.

7  Click the Use Limits radio button and enter 1000 in the Min 
field as shown in the figure below.
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8  Click Apply and the plot will update with a new minimum 
field display.
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9  Click Close. The plot should resemble the following one: 

10  Click File>Save to save all of the operations up to this 
point.
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7 Adding Variables to the 
Solenoid Model
Now you are ready to use Maxwell to solve the 
solenoid problem parametrically. This chapter shows 
you how to add design variations to the solenoid 
model.

Add a geometric variation to the solenoid model. 
This will define the distance between the core 
and the plugnut as a variable that can be swept 
during the solution.
Define a source current function and assign it to 
the coil
Request that the force acting on the core and the 
coil inductance be calculated as a function of 
core position and coil current during the solution.
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The Solenoid Model
The geometric design variable that you are going to define in 
this chapter represents the gap increase from the nominal 
design between the solenoid’s core and plugnut. By varying 
the distance between these objects, you can model the sole-
noid’s behavior over a range of core positions. During the 
solution, deltagap will vary from 0.0 to 0.5 inches, represent-
ing a spacing between the core and plugnut of 0.075 to 0.575 
inches as shown. The core never actually touches the plugnut 
— there is a minimum air space of 0.025 inches.

11  Choose File>Save As from the menu and save a copy of 
the project to Actuator_param. This will become our 
parameterized project.

air space

0.025

0.575

0.075

Min. gap

Max. gap

core

plugnut
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Adding Geometric Variables
There are many way to parameterize a geometric model in 
Maxwell’s modeler. For this example, you will use the 
Edit>Arrange>Move command and assign a variable to the 
move distance. The variable can then be modified by the 
Parametric Analysis system to move the core location for the 
sweep analysis.
Other options for varying an object would be to use variables 
in place of exact coordinates in the rectangle command used 
to create the core as an example. Then the corners of the 
rectangle can be varied allowing the core to move and change 
shape as well. However, all variations of geometric parame-
terization use the basic procedure you will follow here:

• Assign a variable to one or several points in the creation of a 
geometric object.

• Provide a default value for the variable.
• Specify the variable is to be used for Optimization, Sensitiv-

ity, or Tuning Analysis. Local design variables are automati-
cally available for Parametric Analysis.

• Indicate the range of values the variable may take during 
the Parametric Analysis.

Add a Variable to the Core Object
You will now add a simple linear movement to the core object 
using the move command.
1  Select the core object by clicking on it in the Modeler Win-

dow or by selecting it in the history tree.

2  Choose Edit>Arrange>Move from the menu. The modeler 
switches to move mode and prompts you for a reference 
point in the status bar.

3  Enter a reference point by clicking at the origin. Option-
ally, you may enter (0, 0, 0) in the keyboard entry area of 
the status bar and press the Enter key.

4  Enter a target point along the Z-axis by clicking the mouse 
along the axis. Optionally enter (0, 0, 0.2) in the keyboard 
entry area and press the Enter key.
Adding Variables to the Solenoid Model 7-3



Getting Started with Maxwell: Designing a Rotational Actuator
5  After entering the target point, the properties window will 
update with the Command tab as shown. 

Alternatively, you may have the Properties dialog appear 
if you have the option Edit Properties of New Primitives 
set under the Modeler Options command
Select the Value field of the Move Vector row and enter 
deltagap in the Z-axis direction. In addition, make sure 
that the X-axis and y-axis movement is zero. Press Enter.

6  The Add Variable dialog will be displayed indicating that 
you have entered a variable in a numeric data field. 

Note It is not important what points are selected for the move 
command. You are just creating the move command in the 
model history. The exact movement will be controlled by the 
variable you set up next.
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Enter 0.0 in into the value field of the dialog as shown.

7  Click OK to complete the geometric variable assignment.

Set the Coil Current to a Variable
Variables may be used in material, boundary and source exci-
tations as well as for geometric movement or shape 
alteration. In this section we will modify the coil current 
excitation to make it a variable available for parametric anal-
ysis.
1  In the Excitations area of the Project Tree, select the 

Current1 excitation by Double-Clicking.

2  The Current Excitation dialog will be displayed. Replace 
10000 in the value field with the variable curr and click 
OK.

3  In the Add Variable dialog, enter 10000 A into the value 
field as shown below. Click OK to complete the variable 
assignment.
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Set Variable Ranges for Parametric Analysis
Once variables have been added to the project, you must 
specify the range over which you want the variables to be var-
ied in the analysis.
1  Begin by selecting Maxwell2D>Optimetrics Analysis>Add 

Parametric from the menu. The Setup Sweep Analysis dia-
log is displayed.

2  In the Sweep Definitions tab click Add. The Add/Edit 
Sweep dialog is displayed with a default variable selected.

3  Verify that the variable is set to deltagap and Linear Step 
is selected as the sweep type. Enter the Start, Stop, and 
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Step size information from the table below.

4  After entering the data listed, click the Add button to 
transfer the sweep spec to the table on the right.

5  Switch the selected Variable to curr and the sweep type to 
Linear Count. Complete the current sweep entry from the 
following table.

6  After entering the data listed, click the Add button to 
transfer the sweep spec to the table on the right.

7  Verify that two sweep entries exist in the table on the 
right side of the dialog and click OK.

8  In the Setup Sweep Analysis dialog, select the Options Tab 
and click the checkbox next to Copy geometrically equiv-
alent meshes. This will allow the simulator to reuse 
meshes for the coil current variations and save meshing 
time and overall analysis time.

9  Also in the Options Tab, make sure the Save Fields and 
Mesh checkbox is selected.

10  Finally, select the Calculations Tab. Click on the Setup 
Calculations button to display the Add/Edit Calculation 
dialog.

11  Select Force under Category in the Trace Tab and click 
the Add Calculation button.

12  Select L under Category in the Trace Tab and click the 
Add Calculation button.

13  Select Done to return to the Setup Sweep Analysis dia-

Value Data

Start 0.000

Stop 0.500

Step 0.050

Value Data

Start 0

Stop 1500

Count 11
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log. The dialog should now contain two calculations to be 
performed during each parametric analysis step as shown 
below.

The basic Parametric analysis setup is complete; however, it is 
instructive to note a few additional capabilities of the Setup 
Sweep Analysis before dismissing the dialog. 

• The Table Tab can be used to edit individual entries or to 
add or delete entire rows of the table. 

• The General Tab allows you to set the values for any vari-
ables the design may contain that you have chosen not to 
include in a sweep. In addition, you can select the solution 
process parameters by selecting a setup in the Sim Parame-
ters section of the dialog.

• In the Options Tab you specify whether you want to save 
the Fields and Mesh for post processing purposes. 

14  Click OK to dismiss the dialog.
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Redefining Zero Current Sources
The variable spreadsheet is now filled. It has 121 entries 
(called setups) in it, one for each combination of the values of 
deltagap and curr. But you still have a little more work to do. 
You swept the curr variable starting at 0 amperes; however, it 
would be a waste of time to solve for a zero solution. In addi-
tion, since we want to re-use the mesh, we need to make sure 
that we start off with a solution that will provide good mesh-
ing overall. Therefore, you need to edit the spreadsheet and 
replace all the zeroes in the curr column with -1 ampere.
To accomplish this, do the following:
1  In the Project Tree, double-click on ParametricSetup1 in 

the Optimetrics folder.

The Setup Sweep Analysis dialog appears.
2  Select the Table tab.
3  Scroll through the table and change each row containing 

0A for the variable curr to -1A.
4  Click OK to complete the changes.
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Save Variables and Parameter Setup
Having added variables for both the geometric variation and 
the coil current; as well as, defining the sweep ranges for 
each, it is a good time to save the setup.
•    Choose File>Save.
The Solenoid_param geometry is saved and you are now 
ready to move on to the solution of the parametric model.
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8 Generating a 
Parametric Solution
Now that you have added physical constraints to the 
geometry and set up the parametric variable table, 
you are ready to generate a parametric solution for 
the solenoid model. You will do the following:

Generate the magnetostatic solution for each 
variant on the original model.
Compute the force on the core as a function of 
the core position and the current in the coil. 
(Since you requested force using the Parameters 
command, this automatically occurs during the 
parametric solution process.).
Compute the inductance in the coil as a function 
of core position and the current in the coil. (Since 
you requested coil inductance using the 
Parameters command, this automatically occurs 
during the parametric solution process.).
Review the Convergence, Profile, and Force 
results of the Parametric analysis.
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Model Verification
You can quickly verify that the spreadsheet contains only valid 
geometric sweep parameters for the geometry.
To verify the model:
1  Choose View/Animate. 

The setup animation window appears.

2  Enter 0in for Start, and 0.5in for Stop. These values are 
consistent with the values used in the sweep setup.

3  Click OK. 
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4  The Animation dialog is displayed and the modeler win-
dowshows the geometry animated with the motions of the 
core object over the range of values for deltagap.

5  Choose Close in the Animation dialog to end the model 
animation.

Note Note that over the range of values used for deltagap, there is 
no geometry overlap.
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Start the Parametric Solution 
Now that you have examined the geometric parameters, the 
problem is ready to be solved. As a general practice, you 
should first solve the nominal problem to make sure that the 
problem is set up correctly. If the nominal problem solves 
properly, then the parametric solution should be sufficient.

Solving the Nominal Problem
To solve the nominal problem: 
1  In the Project Manager window, right-click Setup1 under 

Analysis and select Analyze on the shortcut menu.

A solution is generated for the nominal values of the sole-
noid parameters.

2  Once the solution has completed, right-click Setup1 under 
Analysis and select Convergence to view the results. If 
the solution progressed normally, you will see the number 
of Triangles increasing with each pass, and the Energy 
Error decreasing to less than 1%.

Solving the Parametric Problem
You have set up your parametric table with each row to be 
solved. Depending on your computer, each row will require a 
few minutes to solve. During the setup you selected Copy 
Geometrically Equivalent Meshes which will improve the 
solution time; however, you may want to start the solution 
when there is at least 10 to 15 minutes available for process-
ing.
To start the parametric solution: 
• Right-click ParametricSetup1 under Optimetrics in the Project 

Manager window and select Analyze on the shortcut menu.
The solution process begins.

Note Do not be alarmed if the values you obtain for percent energy 
error, total energy, inductance, or force differ slightly from the 
ones given in this guide. The results that you obtain should be 
approximately the same as the ones given here.
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Monitoring the Solution
When performing Parametric Analysis the dual monitoring bar 
shown below is displayed in the Progress window. The top bar 
displays the progress regarding the solutions in the analysis 
table. In this case, 120 total analyses are to be performed as 
a result of the variation of the deltagap and curr variables..

The bottom progress bar shows the standard progress in the 
solution of each individual row of the analysis table.
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Viewing Parametric Solution Data
During the solution process, you may view solutions, the solu-
tion convergence, and the solution status or profile of any 
row in the table.
To view the parametric solution data during the solution pro-
cess:
1  In the Project Manager window, right-click on Results and 

select Solution Data from the shortcut menu as shown.

The Solutions dialog is displayed. By default, the design 
variation is set to the Nominal problem.

2  Click on the ellipsis button next to the design variation to 
display the Set Design Variation dialog as shown.
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3  Uncheck the Use nominal design checkbox.
4  Select any row in the table by clicking to highlight it and 

click OK
5  The design variation in the Solutions dialog now shows the 

profile, convergence information, force, etc. associated 
with the selected variable values.
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Viewing Parametric Convergence Data
After selecting a design variation, choose Convergence to 
monitor how the solution is progressing. 
•    For example, if you choose the variation corresponding to 

Curr=-1A and deltagap=0.1in, then choose Convergence, 
you will see something like what is shown below: 

•    The mesh has been iteratively increased as shown in the 
Triangles column and the corresponding Energy Error has 
been decreased to less than 1%.

•    You may change the View from Table to Plot by clicking 
the Plot radio button and selecting which quantities 
should be plotted on the X and Y axes.
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Plotting Parametric Convergence Data
In addition to viewing the results for each design variation, 
you may view the results as a function of the design variable 
values. 
1  In the Project Manager window, right-click 

ParametricSetup1 under the Optimetrics folder and 
select View Analysis Results.

The Post Analysis Display dialog appears as shown below: 

2  Using the pull down menu, select deltagap as the variable 
to plot on the X axis. 
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For parametric analyses involving multiple variables, the 
Setup Plot dialog appears.

3  Select 1050A for the variable curr and click OK.
4  In order to review the Inductance of the coil, use the Y 

axis pull down menu and select L(Current1, Current1).
5  You may inspect the performance at other values of curr 

by clicking the Set Other Sweep Variables Value button 
and selecting the value of interest.
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Viewing Parametric Solver Profile
Individual design variations may be inspected to see the 
solver profile as well.
1  In the Post Analysis Display dialog, select the Profile tab.

The following screen appears: 

2  The Start, Stop and Elapsed time for each variation is 
shown in the table. Select Variation 8 by clicking on it in 
the table.

3  Click the Solver Profile button.
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4  The Solutions dialog is displayed with the selected design 
variation loaded and the profile tab selected.
The following information is displayed for each completed 
adaptive field solution and mesh refinement step. If more 
data is available than can fit on a single screen, scroll bars 
appear.

5  Click Close to dismiss the Solutions dialog and return to 
the Post Analysis Display dialog.

6  Click Close to dismiss the Post Analysis Display dialog.

Task Displays the system command that was 
used.

Real time Displays the time taken to complete the 
step.

CPU time Displays the time taken by the CPU to 
complete the step.

Memory Displays the amount of memory used.
Information Displays the number of triangles in the finite 

element mesh, size of the matrix, disk space 
used and other information relevant to the 
solution process.
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9 Plotting Results from a 
Design Variation
With the result of design variations available, you can 
use the post processor to create reports and plot 
fields with multiple variations. You will do the 
following:

Create a report of force vs. gap with multiple 
traces for each current level.
Set the Design Variation for plotting fields from a 
design variation.
Animate a field plot using the Design Variation 
values for the gap.
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Access Parametric Post Processor
You will use the Post Processor to plot the force on the core as 
a function of position for different values of coil current.
To access the Post Processor:
1  Select Maxwell2D>Results>Create Magnetostatic 

Report>Rectangular Plot. 

Alternatively, right-click on Results in the Project Man-
ager window and select Create Magnetostatic 
Report>Rectangular Plot from the shortcut menu.
The Report dialog appears.

2  Since we want to plot Force as a function of position, 
make sure that the variable deltagap is selected as the 
Primary Sweep variable.

3  Also, make sure that Force is selected under the Category 
list.
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4  Click on the Families tab to set the values of curr to plot.
5  In the Families tab, you may select Sweeps or choose indi-

vidual variations for the variable curr as shown.

6  Click New Report to plot the force versus gap spacing for 
various current values.

7  Click Close to dismiss the Report dialog and view the fam-
ily of curves as shown below.
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Plotting Fields of a Design Variation
In order to plot the fields from a particular design variation, 
you must first have told the software to save the fields from 
the parametric analysis during the setup process. You did this 
in the Set Variable Ranges for Parametric Analysis section of 
this guide.
To plot the fields from a particular design variation:

Apply Solved Variation
1  Tell the software which variation to use by clicking 

Results>Apply Solved Variation from the Maxwell2D menu 
or the shortcut menu.
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The Set Design Variation dialog is displayed as shown.

2  Uncheck the Use nominal design checkbox.
3  Scroll to the curr=1500A, deltagap=0.5in line and high-

light it by clicking on it.
4  Click OK to make it the new “Nominal Design” and be able 

to plot fields.

Note Note the change in the model view as the design variation is 
applied.
Plotting Results from a Design Variation 9-5



Getting Started with Maxwell: Designing a Rotational Actuator
Plot Fields for the Variation
To plot the magnetic field for the variation:
1  Click Edit>Select All in the menu, or click in the modeler 

window and press Ctrl-A. All objects in the model will be 
highlighted.

2  Click Maxwell2D>Fields>Fields>H>Mag_H. 
The Create Field Plot dialog appears.

3  Click Done to accept the plot definition and create the 
field plot similar to the one shown below.

4  Right-Click on the plot Key and select Modify from the 
shortcut menu.

5  Click on the Scale tab.
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6  Since the field plot is dominated by the field in the core, 
click on the Log radio button to see more field pattern in 
the low field regions.

7  Click Close to dismiss the dialog.

Animate the Field Plot Across Variations
In order to see how the field changes with the size of the gap 
you can animate the field as follows:
1  In the Project Manager window, right-click on Mag_H in 

the Field Overlays folder.

2  In the shortcut menu, click on Animate.
3  The Setup Animation dialog appears.

4  All values for deltagap are selected by default. Click OK to 
accept and animate the field plot.

5  Click Export to save the animation as a .gif or .avi file.
6  Click Close in the Animation dialog.
Plotting Results from a Design Variation 9-7



Getting Started with Maxwell: Designing a Rotational Actuator
Exit the Maxwell Software 
You have successfully completed the 2D Magnetostatic Sole-
noid Getting Started Problem. 
1  Save the project plots and reports by clicking File>Save. 

Maxwell V12 will save all data including the plots you have 
created for later use.

2  To exit the software, click File>Exit. 
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