- #1
kheiron1729
- 5
- 0
Hello. I am new here.
Here is the question: Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22:
22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1,000,000.
For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
Output
For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.
Sample Input
1 10
100 200
201 210
900 1000
Sample Output
1 10 20
100 200 125
201 210 89
900 1000 174
I am relatively new to programming. Anyway, I tried. It gave fine answers to me until I am submitted it online at http://www.programming-challenges.com..it said "Wrong Answer!"
Can anyone tell me what's wrong with the code. The language is C++.
#include <iostream>
using namespace std;
//iterates to find the cycle length
int cycleLen (int num, int count) {
if (num == 1)
return count;
else if (num%2 == 0) {
num = num/2;
count++;
cycleLen(num, count); }
else {
num = 3*num + 1;
count++;
cycleLen(num, count);
}
}
//Returning the Max Cycle
int maxCycle(int *list, int total) {
int max = list[0];
for (int i=1; i<total; i++)
if (list > max)
max = list;
return max;
}
//handling a range of numbers
int createArray (int i, int j) {
int total = (j-i)+1;
int* cycles;
int* elements;
elements = new int[total-1];
cycles = new int[total-1];
//placing elements into elements array
for (int x=0; x<total; x++)
elements[x] = i++;
//computing cycles for corresponding elements
for (int x=0; x<total; x++)
cycles[x] = cycleLen(elements[x], 1);
return maxCycle(cycles, total);
}
int main () {
int n1, n2;
cin >> n1 >> n2;
cout << n1 << ' ' << n2 << ' ' << createArray(n1,n2) << endl;
return 0;
}
Here is the question: Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22:
22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1,000,000.
For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
Output
For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.
Sample Input
1 10
100 200
201 210
900 1000
Sample Output
1 10 20
100 200 125
201 210 89
900 1000 174
I am relatively new to programming. Anyway, I tried. It gave fine answers to me until I am submitted it online at http://www.programming-challenges.com..it said "Wrong Answer!"
Can anyone tell me what's wrong with the code. The language is C++.
#include <iostream>
using namespace std;
//iterates to find the cycle length
int cycleLen (int num, int count) {
if (num == 1)
return count;
else if (num%2 == 0) {
num = num/2;
count++;
cycleLen(num, count); }
else {
num = 3*num + 1;
count++;
cycleLen(num, count);
}
}
//Returning the Max Cycle
int maxCycle(int *list, int total) {
int max = list[0];
for (int i=1; i<total; i++)
if (list > max)
max = list;
return max;
}
//handling a range of numbers
int createArray (int i, int j) {
int total = (j-i)+1;
int* cycles;
int* elements;
elements = new int[total-1];
cycles = new int[total-1];
//placing elements into elements array
for (int x=0; x<total; x++)
elements[x] = i++;
//computing cycles for corresponding elements
for (int x=0; x<total; x++)
cycles[x] = cycleLen(elements[x], 1);
return maxCycle(cycles, total);
}
int main () {
int n1, n2;
cin >> n1 >> n2;
cout << n1 << ' ' << n2 << ' ' << createArray(n1,n2) << endl;
return 0;
}